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Introduction  

TELUS PharmaConnect™ is a mobile and web application that provides patients with the ability to view their 

prescription profile, request refills and check the status of their requests.  The mobile app allows patients to 

submit photos of new prescription orders and receive notifications when their prescriptions are ready for pick up.  

Patients are also able to link family members, dependents and pets to the same account so that they can act on 

behalf of those family members. 

The PharmaConnect™ system uses a behind-the-scenes interface called PharmacyLink to communicate securely 

between the Kroll application and the PharmaConnect™ app and website.  PharmacyLink is used for other Kroll 

functionality and you will see it referenced throughout this document. 

 

Configuration 

The Kroll team at TELUS will activate the PharmacyLink interface.  It is important to know that there are several 

configuration settings that are reflected on the PharmaConnect™ app and thus, impact the patient experience.  

Other settings impact how the Kroll system handles the requests submitted by the patient via the app. 

To assist you in your initial configuration of the interface, from the Help Menu on the Start screen, select the 

PharmacyLink Check List. 
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The CheckList provides you with information on what needs to be updated in Kroll in order for PharmaConnect™ 

to work properly and to ensure a positive patient experience. 

Items with a red stop sign must be updated in order for PharmaConnect™ to work.  Items with a yellow yield sign 

are not mandatory however, correcting them will improve the patient experience.  Items with a green checkmark 

have already been completed and require no further update. 

Clicking on the ‘Fix’ button beside each item will take you to the appropriate section of the Kroll 

Configuration. 

NOTE: The user logged into the terminal must have the proper permissions to access and update Store 

Configurations in order to proceed with configuring PharmaConnect™. 
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Default Area Code 

The default area code must be set in Kroll.  Clicking on ‘Fix’ will display the appropriate section of the 

configuration with the field highlighted in blue: 

 

Enter the area code of your pharmacy and click ‘OK’ to save the change.  

When the Check List screen is accessed again, the Default Area Code 

section will now contain a green checkmark.  Continue with any 

remaining sections that require fixing. 

 

 

Store Information 

Your store demographic information will be shown to patients when 

they are searching for your pharmacy.  It is also important to set your 

store’s Latitude and Longitude as this allows the Maps feature of the 

app to pinpoint the location of your pharmacy.  Visit 

https://www.latlong.net/ to find the values for your location. 

 

Store Hours of Operation 

Noting accurate hours of operation for the pharmacy will ensure that 

your patients will know when your pharmacy is open and closed from 

within the app and website.  It is also used when determining the 

expected pick up time for refills.  Should your operating hours 

change during the year, it is important to update this schedule. 

To access the Pharmacy Hours of Operation, click on the Fix 

button of the PharmacyLink Check List screen or at any time, 

access these from File > Configuration > Hours of Operation. 

For each day of the week, enter whether you are open or closed.  

For the days noted as being opened, enter the opening and 

closing times.  Note that times are entered in 24-hour format:  

11AM = 11:00, 11PM = 23:00. 

https://www.latlong.net/
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For holidays when the hours of operation are different, click ‘Ins’ in the Holiday Hours section.  Select the date, 

the open or closed status, and enter the hours of operation on that date accordingly.  Click ‘OK’ to save.  

Note: You will need to enter the holiday dates each year.  You may want to set an annual reminder to create 

the new holiday entries.  If performing this early in the new year, don’t forget to enter January 1st of the 

following year in advance. 

 

PharmacyLink Due Date Category 

When a patient requests refills, they will be provided with feedback indicating the anticipated time that their refills 

will be ready for pick up.  This is the Due Date time that is assigned to the work order and is used to prioritize 

these Rx’s in your workflow queue. 

There are 5 different Due Dates based on the prescription type. 

● New Prescriptions 

● Refill Prescriptions 

● Mixture Refills 

● Refills Requiring Pharmacist Extension 

● Refills Requiring a Doctor Callback 

To access these due times, click on the Fix button of the PharmacyLink Check List screen or at any time, access 

these from File > Configuration > Store > Interfaces > PharmacyLink Due Dates. 
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On the Regular Refills option, use the down arrow to select an existing Due Date/Time entry or click ‘Ins’ to create 

a new entry for prescriptions that have available refills remaining. 

Description          Type      Time 

 

 

Select a Time Type from the drop down menu (select the option that best fits your business model).  Enter a 

relative time if applicable. 

 

Click Save. 

Using the 2 hour example above, if a Refill request is received at 2:00 PM, this will be placed into your ToDo/Data 

Entry queue with a priority/expected pickup time of 4:00 PM. 

Repeat the above for the remaining two options to allow you additional time for the scenarios noted. If Pharmacist 

Extension has been allowed, renewal requests sent through the app will default to this wait time. 
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Any calculated due time that falls beyond today’s closing time will automatically be advanced to the next business 

day.  Also, should a calculated due time fall near your closing time, you can force it to respond with the next 

business day by setting a value in the When calculating due dates… setting shown below. 

 

If workloads change such that an adjustment is necessary to any of these Due date/times, you can return to this 

screen at a later time to select a different entry or insert a new one.  To edit an existing entry, go to File > 

Configuration > Store > To Do > Configure Wait Times.  

 

See Other Options below for information on the remaining options on this PharmacyLink configuration screen. 
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Print 2D Barcode 

Including the 2D barcode on the vial label and/or the receipt will allow the patient to order a refill via the mobile 

app by scanning the barcode instead of manually entering the Rx number.  This is not mandatory, however when 

set up, improves the patient experience.  Please be aware that the scanning of the vial label linear barcode will 

NOT work when requesting refills from the app. 

To access the barcode options, click on the Fix button of the PharmacyLink Check List screen or at any time, 

access these from File > Configuration > Store > Labels > 7-Bar Codes.  Place a check beside the Vial and 

Receipt options. 

And although it is not mandatory, enabling the 

Print script image barcode warning label will 

allow you to affix this additional bar code label to 

the original Rx that the patient will hand in thus 

allowing the system to automatically attach the 

prescription image to the original Rx when 

scanned back into the system. 

 

Nursing Home Type Set 

You may have retail patients attached to a nursing home for the purpose of providing regularly scheduled 

compliance packaging via the Kroll batch fill process.  Those same patients may still be receiving non-compliance 

pack prescriptions.  You will want to prevent a patient from requesting refills for the batched compliance pack Rxs 

but allow refill requests for the others. 

By designating the nursing home as a Compliance Pack or Retail type, when the patient views their prescription 

profile on the app, the non-batched Rxs will allow refill requests while the batched Rxs will display ‘Refills 

managed by pharmacy’. 

The PharmacyLink Check List screen will display which nursing homes do not have a Type value set.  Even if the 

Check List does not indicate a problem, if you have a nursing home that is used for retail patients, you may want 

to ensure the Type is set appropriately. 
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Click ‘Fix’ to access the NH List Form or from the Start 

Screen, select NH > Edit Nursing Home List. 

Highlight the nursing home(s) noted on the Check List 

screen and click F2. 

Click on the arrow adjacent to the Type field.  Select the 

appropriate option from the list that displays.  If this home is used for retail patients, select either Compliance 

Pack or Retail.  Click ‘Save’, then ‘Close’. 

 

 

 

 

 

 

 

 

 

 

 

 

Drug Pictures 

PharmaConnect™ uses the drug images in your Kroll system, displaying them when the patient views their profile.  

Therefore, it is important that they are as up to date as possible.  If the PharmacyLink Check List displays a yellow 

warning, your drug images may need to be updated.  To update your system with the latest images, from the Start 

Screen, click File > List Program Updates.  A list of available updates displays.  Run the latest Drug Picture 

Update.  If there is none listed or if after running the latest update the CheckList screen still notes a yellow warning, 

contact the Kroll Help Desk for assistance. 

Keep your drug images up to date by executing the Drug Picture Update whenever one is made available.  
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Auto Print PharmacyLink Registration Document 

Kroll has the capability of automatically generating a registration document that can be provided to the patient.  

This document includes a marketing message about the benefits of using PharmaConnect™ along with the 

patient-specific bar code that the patient can use to complete their registration at home.  When activated, the 

rules around the generation of this document are as follows: 

● Patient must be human (Patient Type field in the patient card must = Human) 

● Patient must be 18 years of age or older 

● Not in a NH 

● There is no caregiver registered 

● Patient is not yet registered with PharmaConnect™ 

● The patient has a registration that is pending and the pairing code has expired. 

In order to auto print the PharmacyLink registration document, two elements need to be in place: 

1. The Auto generate PharmacyLink patient registration document for Network field on the 

PharmacyLink interface screen must be set to the same network that is noted in the Networks field. 

 

2. The ‘Print Patient PharmacyLink Registration document’ workflow action must be inserted into all 

applicable workflows within your Kroll system.  If the print action is not currently included, please reach 

out to our Kroll Team to have the action added into applicable workflows. 
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Store Owner Contact Information  

In the event something should happen with the service, an owner or pharmacy manager can be contacted. To 

add the contact information, either click on the Fix button on the PharmacyLink Checklist screen OR from the start 

screen, click File > Configuration > Store > Interfaces > Pharmacy Link – double click on the line item noted 

under the Networks section on the right.   The Pharmacy Link screen displays. 

 

 

Enter the Pharmacy owner/Pharmacy Manager 

contact information in the Store Down Contact 

Info field. It is being suggested that at a 

minimum the individual’s name, best phone 

number and email address be noted. Click 

‘Save’ when complete. 

 

 

 

Configure Patient Reports 

This feature, when enabled, will allow the patient to request reports through PharmaConnect. The report is 

retrieved from Kroll in the background and saved to the patient’s documents. Once available, the patients can 

retrieve the PDF.  

To access these Report Configurations, click on the Fix button of the PharmacyLink Check List screen or at any 

time, access these from File > Configuration > Store > Interfaces > PharmacyLink. 
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● Enable the reports that you want made available to patients by 

checking the box above the report. 

● For each active report, click on the Configure button.  A report 

template screen displays. 

Select the options within each report that you want active.  This 

template ensures a consistent output each time the report is selected by 

a patient either via the app or the website.  Click ‘Save Template’ when 

complete.  Repeat for each report that you have activated.   

If your pharmacy has a signature tablet or the Virtual signature tablet 

module configured in Kroll, you will also have the option to embed a 

Pharmacist’s signature onto the report. 

Please be aware that these reports when generated by pharmacy staff 

in Kroll are NOT affected by the templates saved. 
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Other Options 

While the PharmacyLink Checklist will identify critical configuration options, there are other options that may 

improve both the patient and pharmacy user experience.  

To Do Origin 

Including this column header in your F9-Workflow screen will provide visibility as to the origin of the Rx in your 

ToDo/Data Entry. 

To add the To Do Origin as a column header: 

1. From the Start Screen, select F9-Workflow 

 

2. If the To Do Origin column does not already exist, right-click on the column headers and select ‘Change 

Columns’. 

 

Scroll down until you see To Do Origin.  Click on the box and then select the Move Up or Move Down 

button to place this header option in the position you feel is best. 
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3. Click OK. 

 

Interface options 

From the Start Screen, select File > Configuration > Store > Interfaces > Pharmacy Link. 

 



   

PharmaConnect™ User Guide  15 
 

 

 

1. You can define the schedules that the PharmaConnect™ app will consider as narcotics.  This will be used 

for the ‘Narcotic’ option in the next section.  Click F2 to designate which schedules will be considered 

narcotics. 

2. These options will enable certain features to be used by the patient and/or the pharmacy team. 

■ Combine Call Doctor Callback status. When this option is checked, the Patient will see “Awaiting 

Callback from Doctor” on the App after submitting a refill request for a prescription with no refills (if that 

option has been enabled). If it is not flagged on, the App will show either “Waiting for Pharmacy to 

Phone” (when Callback is set to Call Doctor) OR “Awaiting Callback from Doctor” (when Callback is set 

to Wait for Doc). 

■ Allow Pharmacist Extension for Refilling Regular Rxs with no Refills left – If your pharmacy allows 

for Pharmacist extensions for Regular prescriptions, enable this option. Renewal Requests through the 

app will be sent directly to the Rx To-Do/Data Entry queue. If not enabled, the patient may not be able to 

submit a refill request, specifically if the Allow Call Doctor option is also disabled. They will be given the 

option instead to call the Pharmacy or Doctor. 

■ Allow Call Doctor for Regular Rxs with no Refills left – If your pharmacy allows for Request 

Renewals to be sent to physicians from the pharmacy on the patient’s behalf, enable this option. If Allow 

Pharmacist Extension is not enabled, renewal requests from the app will be sent directly to Doctor 
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Callbacks. If Allow Call Doctor is not enabled, the patient may not be able to submit a refill request, 

especially if the Allow Pharmacist Extension option is also disabled. They will be given the option instead 

to call the Pharmacy. 

■ Allow Call Doctor for Narcotic Rxs with no Refills left – This option is the same as the Allow Call 

Doctor for Regular Rxs, but is specific to Narcotic prescriptions and other drug schedules specified in 

section above it. 

■ Allow Caregiver Registration – will allow both the patient and the pharmacy to link a secondary patient 

record/PharmaConnect™ account to a caregiver’s account.  For example, a parent to a child. 

■ Allow patients to submit photos of new prescriptions using Web or Mobile App – will allow the 

patient to take a picture of their original written prescription and send it via the app to your store’s 

ToDo/Data Entry queue.  NOTE: Currently this feature is only available on the app and only in certain 

provinces where regulations allow it.  (Alberta and Newfoundland do not allow the processing of a 

prescription until the original is in hand) The ability to request a new Rx with the image from the Web will 

be available in the near future. 

■ Allow delivery for New Rxs - This option will allow patients to select delivery on the request of a New 

Rx. This requires that participating pharmacies have a process in place to obtain the authoritative copy of 

the New Rx from the patient before the prescription is release or shipped*.  

* Pharmacies that enable the option to allow patients to submit photos of New Prescriptions are required 

to familiarize themselves with the regulations pertaining to prescription submission in the provinces that 

they operate in and are responsible to govern themselves accordingly.  

■ Allow patients to self-register - This option allows patients to link their PharmaConnect account to their 

Kroll patient profile using a prescription number. When using this method, patients are required to 

respond to demographic information challenges. These challenges are based on the information in Kroll 

such as Mobile Phone, Postal Code and/or health card number. 

■ Patient registration pairing codes expire after __ days - This config allows pharmacies to set an 

expiry value for the pairing code displayed on the printed patient leaflet. This value can be set to align 

with the pharmacy’s operations and must be set between 7 or 99 days.  
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PharmaConnect™ Patient Registration 

To start using PharmaConnect, a Kroll patient profile must be linked to a PharmaConnect™ account that the 

patient has or will create via the mobile or web app. 

This linking using 1 of 3 methods: 

1. By generating a unique code from the Kroll patient profile and providing this to the patient to enter into 

their PharmaConnect™ account at their convenience 

2. By entering a code into the Kroll patient record that is generated in the patient’s PharmaConnect™ 

account 

3. or a patient can use Self-Registration, if enabled, by using an Rx number and entering their information to 

link to your pharmacy on their own. 

Registration Using the Barcode Generated in Kroll 

1. Access the patient record in Kroll. From the View menu on the lower right-hand side, select 

‘PharmacyLink Access’.  Click on the ‘Ins’ button and select ‘This Patient’. 
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2. On the PharmacyLink Registration form, click Generate a new registration code to give to the patient. 

  

Click ‘OK’ to generate the registration code. 

 

Provide the printed document that includes information about PharmaConnect, along with their personal 

registration code.  To generate this form, click Print.  Below is an example of the form: 
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Please remind the patient that the generated code expires.   Should the patient attempt to register after the code 

expiration, they will need to request a new code be generated by the pharmacy. 
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Registration Using the Barcode Generated in the App 

If the patient has already created their PharmaConnect™ account, the app has the ability to generate a barcode 

that you can use to instantly link a Kroll patient.  The patient may either come into the pharmacy with their phone 

or call you with the generated code in order to complete the linking process. 

To access the code within the 

app, from the Home screen, tap 

Link your account now. 

On the Link to Pharmacy screen, 

tap Display my account code. 

The barcode along with the user 

token is displayed. 

  

 

 

1. To complete the linking using the application-generated code, access the patient record in Kroll and from 

the ribbon bar, select PharmacyLink Access.  Click on the ‘Ins’ button and select ‘This Patient’.  The 

PharmacyLink Registration form will appear. 
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2. If you have a barcode reader and have access to the phone with the barcode shown, you can simply scan 

the barcode while this registration form is displayed.  Otherwise, select the Scan or Type in the user 

token from the patient’s Mobile Device and enter the code manually. 

 

3. Click OK to complete the linking process.  

When using this method, there are no validation steps performed between Kroll and PharmaConnect. As such, it 

is important to ensure you take the time to ensure you have the correct patient profi le before using this method to 

link the patient to your pharmacy. 

Self-Registration for Patients 

PharmaConnect™ provides the ability for patients to link to your pharmacy independently, without the use of a 

registration code. In order for the patient to be able to use this method, the following fields must be complete in 

the patient profile: 

● First Name 

● Last Name 

● Postal Code 

● Phone Number 

● Email (Optional) 
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If these fields are not completed the verification process used when a patient attempts this method will fail. When 

a patient uses this method, they are expected to respond to information challenges that are related to the fields 

above. 

Linking a Dependent to a PharmaConnect™ Account 

PharmaConnect™ provides the ability to link dependents to a caregiver’s PharmaConnect™ account.  This 

provides the caregiver with visibility to the dependent’s profile via their own account as well as the ability to 

request refills and send in new prescriptions on behalf of the dependent. 

Caregiver Already has a PharmaConnect™ Account Created and Linked 

● Access the dependent’s patient record in Kroll.  From the ribbon bar on the right-hand side, select 

PharmacyLink Access.  Click on the ‘Ins’ button and select ‘Create and authorize a new agent’. 

 

● Using the Selection tool select the Caregiver for this patient 
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● Once the Caregiver is selected, you will be asked to identify the relationship to the dependent patient that 

this person (agent) holds. Also required are the permissions assigned to this agent or Caregiver.  

 

If the dependent is a minor, all permissions will be pre-selected. If the dependent is an age of majority 

patient only all permissions except those with legal implications are pre-selected.  
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The permissions are defined as follows: 

● View Rxs - This is the default permission and allows only view access on PharmaConnect. 

● Order or pick up Rxs - If this permission is not granted, the agent will not be permitted to order 

prescriptions on pharmaconnect and will only be allowed to view them. 

● Receive counselling on patients behalf - This permission is integrated into the counselling screens for 

functions like medication reviews and allows the pharmacy user to select the agent as the person who 
received the counselling. 

● Request reports - This permission is integrated in the PharmaConnect feature that allows users to 

request one of three available reports.  

● View accounts receivable - This permission allows agents to view Accounts receivable statements in 

PharmaConnect. This requires the activation of the PharmaConnect Paperless AR Module. 

● Add, view or cancel appointments - This permission allows the agent to book appointments on the 

dependents behalf. This requires the activation of the PharmaConnect Online Appointment Booking Module. 

● Change demographics - This permission allows the agent to update profile information via 

PharmaConnect. 

● Change plans - This permission allows the agent to update plan information via PharmaConnect. 

● Change packaging preferences - This permission is not yet integrated into any specific area of the Kroll 

or PharmaConnect application and is for reference only. 

● Sign legal documents - This permission allows the agent to sign consent forms on PharmaConnect or 

other legal documents in Kroll on the patients behalf.  

● Authorize or revoke agents - This permission allows the agent to assign or authorize other agents for 

the patient.  

 

The agent record can optionally be assigned an expiry date. Once that date is reached all permissions 

are rescinded until such time as either the dependent is granted again by the dependent (age of majority) 

or a request is submitted and approved by the pharmacy (Minor dependents). 

When the Authorized Agent form is completed and saved you will be asked to complete the 

PharmacyLink Registration for the dependent. 

 

Two options are provided: 
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Generate a new registration code to give to the patient - This option prints a predefined instruction 

sheet or leaflet that provides step by step instructions guiding the user through the steps to complete the 

linking using a code. This code can be typed in or a ‘QR’ code is also provided that can be scanned using 

mobile devices. This instruction sheet and code expire and the expiry date is clearly displayed on the 

sheet. If a user attempts to use an expired code, they will be instructed to obtain a new one from the 

pharmacy.  

Scan or type in the user token from the patient’s mobile device - If the user has already created a 

PharmaConnect account they will have an option on the home page to display a code to the pharmacy. 

This code can be either typed in by the pharmacy user or if hand held scanners are used in the pharmacy 

the code can be scanned. 

The PharmacyLink Access record is now created for the dependent with the ‘caregiver’ type and name 

shown. 

If the leaflet option is selected. the PharmacyLink record will appear in a PENDING state. It will remain in 

a PENDING state until such time as the code is entered in PharmaConnect or it EXPIRES. If the code is 

entered in PharmaConnect the record will change status to REGISTERED. 

 

If the option to scan the users code is selected the PharmacyLink record is immediately created as 

REGISTERED. The user can navigate back to the home page of the PharmaConnect app on their mobile 

device and the linking will be complete. 
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To protect the information of certain patients an option has been provided in the PharmacyLink access section 

that prevents Self Registration from being performed on this profile. While rare, some patients require this to 

prevent a family member or someone else from registering access to their profile without permission. If this option 

(shown below) is invoked only the Leaflet or Users Code methods can be used for registration. 

 

It is also recommended that when linking a caregiver to an adult dependent patient profile, that verbal consent is 

obtained and documented. At any point, if consent is withdrawn, simply delete the link and the caregiver will no 

longer have access to the dependent patient’s profile. 
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● To access the dependent profile on the app, the primary patient/caregiver must log into the 

PharmaConnect™ app. 

From the Home screen menu icon  

select Shared profiles.  The dependent is 

displayed under the Profiles linked to 

your account section and shows that the 

dependent is now linked to your 

pharmacy. 

Tap on the dependent’s name to access 

their profile details. 

  

 
Caregiver not Linked or does not have a PharmaConnect™ Account 

A caregiver can be given access to a dependent’s profile even if the caregiver has not been set up with 

PharmacyLink access.   

■ The caregiver may not yet have created a PharmaConnect™ account. 

■ The caregiver may have a PharmaConnect™ account but is not yet linked to their Krolll profile.  Either 

they haven’t performed the linking yet or they don’t need access to their profile.  

■ The caregiver does not exist in your system – but their dependent does. 

1. To link a dependent, access the dependent’s patient record in Kroll.  From the ribbon bar on the right-

hand side, select PharmacyLink Access.  Click on the ‘Ins’ button and select Patient’s Agent. 
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If the patient already has an agent, a drop down list will become available, select the desired agent, confirm the 

agent permissions and submit the selection. If no Agent is available, select Create and authorize a new agent. 

 

2. Search for the parent/caregiver by typing their name or pressing the F2 button. 



   

PharmaConnect™ User Guide  29 
 

Note: The caregiver may not be a patient at your pharmacy.  If they do not exist in your system, use the Insert 

button on the search form to create their patient record now. 

 

3. After locating / creating the caregiver and returning to the PharmacyLink Agent Selection screen, select 

the Relationship to patient from the drop-down, select the desired permissions and optionally set an 

expiry date if one is desired. Click Save once complete.. 

 

If the information already created in the PharmacyLink account EXACTLY matches the information for the 

dependent in their F3 Patient card the system will automatically complete the linking. the screen will refresh after 

the Save button is clicked and the PharmacyLink access record will be created in a REGISTERED state. No other 

steps are required. This is achieved automatically as the system already knows the Agent as a linked and 

registered PharmacyLink account holder and the dependent profile on that account can be verified automatically 

in the background. If the info on the PharmacyLink account is not an exact match the system will prompt the 

pharmacy user to select a linking method: 
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4. You can generate a unique barcode and provide this to the caregiver for them to enter into their 

PharmaConnect™ account at their convenience.  If they have their phone with them and have already 

created their PharmaConnect™ account, you can scan the barcode or enter the user token into the Kroll 

patient record that is generated by the app. 
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The caregiver will need to use the following steps on the app to complete the registration of their dependent. 

Log into the app.  From the 

Home screen, tap the menu icon 

 and select Profiles. 

On the Add a New Dependent 

screen, complete the fields shown, 

optionally adding a nickname. 

The new profile is created. 

  
 

Tap Add a new dependent now. When done, tap Create profile. Tap Link to a pharmacy. 

 

At the Link to Pharmacy screen, the caregiver can tap on any of the three options depending on what you have 

or will provide them with on the PharmacyLink Registration screen.  
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If presenting the phone to you, tap on At the Pharmacy? Show your code and either use your barcode reader to 

scan the code or select the bottom option to type in the user token that is displayed below the barcode shown on 

the phone. 

If you had generated a printed registration form, the caregiver would tap on Scan Pharmacy Barcode and scan 

the barcode from your form. 

Optionally, the caregiver can tap on Enter code from pharmacy and enter the token code from the bottom of the 

printed barcode you provided or have you read them the code from your Kroll screen when you select the 

Generate a new registration code option. 

Once the caregiver has completed any of the options above, they will be presented with the Verification screen. 
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On the Verification screen, complete 

the fields shown.  Note: These fields 

must match exactly to those 

recorded on the local Kroll patient 

card for the caregiver. 

The caregiver PharmaConnect™ 

account is created. 

 
 

Tap Link My Account. Tap Return to Home. 

 

Viewing PharmacyLink Registration Information 

At any time, you can view the PharmacyLink registration information for a patient. 

Access the patient record in Kroll.  From the ribbon bar on the right-hand side, select PharmacyLink Access and 

double-click the entry or press the ‘F2’ button.  The Patient PharmacyLink Details screen will appear.  
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The form will show the details of the PharmacyLink record and list any dependents for the given parent/care-giver. 
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Using the PharmacyLink Barcode to Search for a Patient 

If the patient presents their phone to you with their PharmacyLink barcode shown, you can scan that code 

anytime you are at a patient search screen.  For example, at your pickup window, if the patient presents their 

phone with the barcode shown, you can scan that code in order to immediately locate the patient.  Optionally, you 

can manually type in the barcode by prefixing it with ‘PL:’ 

Processing PharmaConnect™ Prescription Requests 

From the Start Screen, select F9-Workflow.  View the Rxs To Do queue (or your Data Input queue if you are 

using structured workflow). 

 

If you have added the ToDo Origin column to your workflow screen, inbound PharmaConnect™ Rxs will show an 

origin of PharmacyLink.  Entries that do not contain an Rx number but instead, show (Script Image) are new 

Rxs submitted via the app using the camera to capture an image of the original order.  Entries that show an Rx 

number along with the drug and doctor are refill requests. 
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Refill Requests 

Highlight the desired refill by clicking on it. 

 

Press F-Call up Rx(s). 

 

Continue to process the refill Rx(s) as per your current processes. 

New Rx Requests (in provinces where permitted) 

From the Start Screen, select F9-Workflow.  View the Rxs To Do queue (or your Data Input queue if you are 

using structured workflow).  Highlight the desired new Rx by clicking on it.  
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Press F-Call up Rx(s).  The Sort Pages in Documents form will appear. 

 

On this form, the image that was captured by the patient will be displayed. 

■ Ensure that this field is set to Use to process prescriptions(s).  If not, click the down arrow and make 

the correct selection. 
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■ Any original prescription processed via the PharmaConnect™ app will always have the “Non 

Authoritative Rx Obtain Original” watermark.  This serves as a reminder to obtain the original Rx from the 

patient at the time they pick it up. 

Click ‘Process’.  The Drop Off screen displays. 

 

■ Note that when setting up the new Rx request in the app, the patient has the ability to add a note 

specifically for this Rx. 

■ The display of the Fill Later and Fill Now buttons is a configuration option.  When disabled, there is a 

single button named Finalize Order. 

On the Drop Off screen, you can optionally enter as much information as possible into each of the fields on the 

right side of the screen.  Once done, click ‘Fill Later’ to place the record back into the ToDo or next workflow 

queue to be completed later, or click ‘Fill Now’ (or ‘Finalize Order’) which moves the record to the next step in 

your workflow process. 
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When the record is moved to the next step, depending on how your system is configured, the Create New Rx 

from To Do screen may appear. 

 

Using the image on the left as reference, complete the entry of any remaining fields on the right side of the 

screen. Click ‘Look Up Rx’.  If the drug or doctor fields were not matched, the system will display the appropriate 

search screen.  Make the appropriate selection.   
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Once each field has been successfully populated, the ‘Lookup Rx’ button changes to ‘Save’.  Click ‘Save’.  The 

F12 screen displays. 

 

Review the data one last time before selecting F12-Fill Rx to continue as per current processes. 
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NOTE: The note entered by the patient on the app displays under the Comments tab on the F12 screen. 

 

 

As noted earlier, the image of the prescription provided by the patient via the app is non-authoritative.  As a result, 

you must obtain the original prescription from the patient before dispensing the item.  The watermark on the 

image serves as a reminder to do this.  If your pharmacy has Pickup activated, a message will display for each Rx 

that requires the original to be obtained from the patient. 

 

When you click on the ‘Pickup X items’, an image of the prescription submitted by the patient will be shown and 

you will be prompted to confirm that you have now obtained the original from the patient. 

If your pharmacy does not have Pickup activated, an operational process will need to be defined in order to 

effectively communicate to all involved, the need to obtain the original prescription from the patient. 
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If you employ paperless workflow, once the patient has provided the original written prescription, it must be 

scanned and saved against the original Rx record.  To make this process easier, ensure that the Script Image bar 

code is generated with each Rx.  (File > Configuration > Store > Label > 7-Bar Codes/Print Script image bar 

code warning label.) 

 

When the original prescription is received from the patient, affix the appropriate Script Image bar code(s) to the 

document.  When time permits, scan the prescription into Kroll using the Printed Document Scan /Import 

functionality found under the Utilities Menu on the Start Screen.  The system will interpret the information in the 

barcode and save the scanned image against the correct prescription record(s). 

 

  

 


