Kroll Version 10
Service Pack 25
Payments

Feature Release Notes

April 2022
Table of Contents

Kroll Version 10 Service Pack 25 Payments Feature Release Notes .......................................................... 3

Calendar .................................................................................................................................................. 3

[KRL-5911] Virtual Consultation Waiting Room has been added to the Calendar ...................................... 3

Canada Post .......................................................................................................................................... 3

[KRL-6044] Extend the Kroll Canada Post interface to poll Canada Post for status changes on a delivery order so the patient is notified when it is delivered ................................................................. 3

Configuration ........................................................................................................................................ 3

[KRL-6344] Added a Kroll Config option to enable/disable XML patient import ...................................... 3

Fill ......................................................................................................................................................... 4

[KRL-5820] Kroll changes to support "privileged caregiver" ........................................................................ 4

[KRL-6114] Provide the ability to better document “do not counsel” situations ........................................ 4

Payments .............................................................................................................................................. 4

[KRL-5599] Added a new screen for Accounts Receivable Electronic Payment ............................................. 4

[KRL-5755] Added ToDo type in patient followup for manual payments ................................................... 5

[KRL-5829] Users can now make a Credit Card or an Electronic Funds Transfer (EFT) to prepay an AR account ........................................................................................................................................ 5

[KRL-5837] Users are now able to pickup an Rx if the Rx has not been paid and is charged to a prepay AR account ........................................................................................................................................ 6

[KRL-5919] Moved electronic payment values for Electronic Funds Transfer into Configuration>Store .... 6

[KRL-5920] Added a new EFT strategy for BMO ......................................................................................... 6

[KRL-5921] Added a new tab “Credit Cards/EFT” to the patient AR profile for both post pay and prepay accounts ........................................................................................................................................ 7

[KRL-5924] Only post pay Accounts Receivable/EFT accounts are supported when an electronic payment batch is created ........................................................................................................................................ 7

[KRL-5973] Added a menu option “Charge to Account” on the F12-Rx Fill window ..................................... 8

[KRL-6079] Added a new field "Printing Mode" to AR profile ......................................................................... 8

[KRL-6082] Added a new tab for “Electronic Payments” .............................................................................. 8

[KRL-6122] Changed prepay charges from AR to always create a new invoice based on the work order ...... 8

[KRL-6129] Added a count in brackets for Accounts toolbar on patient edit screen. On the patient card, we now display the total number of Accounts on the right “View” menu ........................................................................ 9

[KRL-6193] Made changes to the “Make AR Payment” window ................................................................... 9

[KRL-6198] Changes to the prepay AR account and OCM ......................................................................... 10

[KRL-6232] Added “Void Payment” for electronic payments ......................................................................... 11

[KRL-6285] Added the ability for the primary account holder, who is not linked to the pharmacy, to register dependants in PharmaConnect ......................................................................................................... 11
[KRL-6341] Deleting pending electronic payments is now allowed

[KRL-6430] For Prepay AR Accounts added a button to manually trigger an OCM notification

[KRL-6444] Allow Deletion of Patient Credit Cards if it has been used previously for an Electronic Payment

[KRL-6457] Create a bulletin for PharmaConnect when AR account has something to pay

Delivery Order

[KRL-6367] Changed delivery order waybill field from disabled to read only

[KRL-6378] Queue up a delivery order OCM shipped message when a delivery order has been shipped

[KRL-6043] Updated Kroll to bring in delivery address from PharmaConnect

Services

[KRL-6590] Kroll Reporting Service Client] Added a new option to enable/disable shipping/delivery notifications for Outbound Communications
Kroll Version 10 Service Pack 25 Payments Feature Release Notes

This document is a compilation of new changes in Kroll Version 10 Service Pack 25 Payments. The purpose is to keep users informed of changes to the software and to help users implement and adapt to those changes.

Calendar

[KRL-5911] Virtual Consultation Waiting Room has been added to the Calendar

Feature
A new option “Virtual Consultation Waiting Room” is added to Calendar screen. The Waiting Room screen will display all patients who have entered the waiting room listed thru their respective Telus Health Virtual Consultation meeting URL.

Canada Post

[KRL-6044] Extend the Kroll Canada Post interface to poll Canada Post for status changes on a delivery order so the patient is notified when it is delivered

Feature
Kroll Reporting Service Client is now enhanced to pull the status update of undelivered Canada Post shipments and is now fed back into Fill and PharmaConnect as necessary.

Configuration

[KRL-6344] Added a Kroll Config option to enable/disable XML patient import

Feature
A new option is added to File>Configuration>Kroll>Modules/XML Patient Import. Once the option has been enabled, the Patient/Rx Import option in Utilities menu is visible.
Fill

[KRL-5820] Kroll changes to support "privileged caregiver"

**Feature**
A patient that is linked to a PharmaConnect user can now grant access to his/her patient profile to another caregiver PharmaConnect user.

[KRL-6114] Provide the ability to better document “do not counsel” situations

**Feature**
Layout and options on the Rx Counseling form has been updated when clicking on Counsel Patient on Pickup option on the side menu of the F12-Fill screen. When a patient submits an order on PharmaConnect, their Counseling selection on checkout is automatically selected on the Rx Counseling form.

Payments

[KRL-5599] Added a new screen for Accounts Receivable Electronic Payment

**Feature**
On the patient AR profile, a new screen, AR Electronic Payment, was added. This allows users the option to make a manual/electronic payment.
[KRL-5755] Added ToDo type in patient followup for manual payments

**Feature**
When making a manual payment, an AR payment ToDo followup record will be added to the Follow-up screen.

[KRL-5829] Users can now make a Credit Card or an Electronic Funds Transfer (EFT) to prepay an AR account

**Feature**
Users can now add a Credit card or an Electronic Funds Transfer (EFT) Type to a Prepay AR account when the pharmacy is linked with PharmaConnect.
[KRL-5837] Users are now able to pickup an Rx if the Rx has not been paid and is charged to a prepay AR account

**Feature**
If the user has a prepay AR account and the Rx has not been paid, changes to allow pickups have been made to the F10-Pickup and Pickup touch screen.

[KRL-5919] Moved electronic payment values for Electronic Funds Transfer into Configuration>Store

**Feature**
In Configuration> Store-> X-AR, the “Electronic Funds Transfer” is now visible to all Kroll Users.

[KRL-5920] Added a new EFT strategy for BMO

**Feature**
In Configuration--> Store -> X-AR, the option “BMO” is now available under Electronic Payment Strategies >EFT.
[KRL-5921] Added a new tab “Credit Cards/EFT” to the patient AR profile for both post pay and prepay accounts

**Feature**
A new tab “Credit Cards/EFT” was added to the patient AR profile for both to display patient’s credit card and EFT accounts.

[KRL-5924] Only post pay Accounts Receivable/EFT accounts are supported when an electronic payment batch is created

**Feature**
Electronic payment batch strategy will only support post pay accounts.
[KRL-5973] Added a menu option “Charge to Account” on the F12-Rx Fill window

**Feature**
A “Charge to Account” option was added to view all available patient pay to accounts.

---

[KRL-6079] Added a new field "Printing Mode" to AR profile

**Feature**
If a patient is linked to PharmacyLink in Kroll, a new field “Printing Mode” is now available on the patient AR profile. This allows users to choose if they want their statements to be Electronic or Paper.

---

[KRL-6082] Added a new tab for “Electronic Payments”

**Feature**
A new tab “Electronic Payments” has been added to the patient AR profile. This displays all the electronic payments made by the patient.
[KRL-6122] Changed prepay charges from AR to always create a new invoice based on the work order

**Feature**
Under File > Configuration Store > X-AR>Add Charges option is set to NEW INVOICE and the Rx is charged to prepay account, then a new invoice is created per work order.

[KRL-6129] Added a count in brackets for Accounts toolbar on patient edit screen. On the patient card, we now display the total number of Accounts on the right “View” menu

**Feature**
On the patient card, the number of AR accounts is now displayed in brackets under View>Accounts.

[KRL-6193] Made changes to the “Make AR Payment” window

**Feature**
On the “Make AR Payment” window, the below changes were made:

- "Credit" has been renamed to "Store Credit"
- "Payment Reversal" has been renamed to "Payment Void"
- "Refund" option has been added
A new option "Interface" has been added to the “Make AR Payment” window.

[KRL-6198] Changes to the prepay AR account and OCM

**Feature**
When a work order is created that is related to a prepay AR account and is linked to PharmacyLink, an OCM notification is created and sent to the patient. If the prepay account is Pre-Authorized, a payment is made towards the work order. If the payment is successful, an OCM notification is created and sent to the patient. If the payment is not successful, a patient follow up is added to the Follow-ups queue with the failure reason.
[KRL-6232] Added “Void Payment” for electronic payments

**Feature**

Users now have the ability to select an electronic payment from the payment tab, right click and select “Void Payment” only applies to reversals that occur on the same date as the charge, provided the electronic payment is made through an integrated credit card and has status “Paid” and is not reversed.

![payment screenshot]

[KRL-6285] Added the ability for the primary account holder, who is not linked to the pharmacy, to register dependants in PharmaConnect

**Feature**

A primary account holder in PharmaConnect, who is not linked to a pharmacy, is now able to register dependants and have their dependants profile created in the pharmacy.

[KRL-6341] Deleting pending electronic payments is now allowed

**Feature**

When a payment has a status of pending, we can now delete the payment. Select the pending payment, right click and choose Delete. Once the payment has been deleted, it is removed from the Payments list.

![payment screenshot]

[KRL-6430] For Prepay AR Accounts added a button to manually trigger an OCM notification

**Feature**

A new option has been added to Prepay AR accounts to manually trigger an OCM notification. By clicking the option, if the patient does not have any existing notifications, then a new OCM notification is sent. If the patient has existing notifications, then a prompt is displayed (see screenshot below).
The new option works with below condition:

- Account has to be prepay
- Current Balance on the patient AR profile > 0
- Credit card needs to be set

[KRL-6444] Allow Deletion of Patient Credit Cards if it has been used previously for an Electronic Payment

**Feature**

Users can now delete a credit card that is not the default payment card from the patient AR profile if it has been previously used.
[KRL-6457] Create a bulletin for PharmaConnect when AR account has something to pay

**Feature**
If the patient has a prepay account that the patient can pay online, and we have a positive balance on the patient AR account, then a bulletin is created on the PharmaConnect patient portal.

**Delivery Order**

[KRL-6367] Changed delivery order waybill field from disabled to read only

**Feature**
When a delivery order has been shipped, the waybill field on the Delivery Order Form becomes read-only instead of greyed out and can be highlighted and copied by user.
[KRL-6378] Queue up a delivery order OCM shipped message when a delivery order has been shipped

**Feature**
When a delivery order is set with a Delivery Type of Mail Order/Courier and the delivery order is marked as Shipped, an Order Shipped message is queued in the OCM queue.

[![American Express](image)]

[KRL-6043] Updated Kroll to bring in delivery address from PharmaConnect

**Feature**
If Delivery Address Flag is enabled on checkout in PharmaConnect, a new delivery address will be saved in Kroll and will become the default delivery address.

[![Kroll ADT Items](image)]
Services

[KRL-6590] Kroll Reporting Service Client | Added a new option to enable/disable shipping/delivery notifications for Outbound Communications

Feature

A new option "Enable Shipping and Delivery Notification" is added in File > Configuration > Store > Interface > Outbound Communication. When the option is enabled, a delivery order that has a delivery type set as mail order/courier, and is shipped and delivered, a notification will be queued for the delivery order status that is marked as shipped or delivered respectively. When the option is disabled, no shipped or delivered notification will be queued.